MaxProf - Users are unable to receive external email messages within Exchange Online – Incident details

Users are unable to receive external email messages within Exchange Online

Resolved
Partial outage
Started almost 2 years agoLasted about 9 hours

Affected

MS Exchange Sever / Outlook Server

Updates
  • Investigating
    Investigating

    User impact: Users are unable to receive external email messages within Exchange Online.

    Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.

  • Resolved
    Resolved

    We’ve completed our deployment of the change, which was a targeted reversion of the code issue causing impact. Users should now be experiencing mitigation, though some residual delays may still occur over the next hour as the change completes.

  • Identified
    Identified

    Current status: We’re analyzing sample throttling IPs from simple messages to confirm whether the issue with the portion of SQL infrastructure is causing impact, before we begin formulating a remediation plan.